Back to overview
Resolved

Connection errors on API, Spot Availability and Price Information

Aug 12, 2026 at 9:17am UTC
Affected services
API Server
Spot Availability
Price Information

Resolved
Aug 12, 2026 at 9:17am UTC

Between 09:17 and 09:50 UTC on August 12, 2026, HTTPS requests to our API, Spot Availability and Price Information endpoints failed during the TLS handshake, and the CloudPilot AI console was unreachable.

The cause was a configuration change to our production load balancer. The configuration was corrected and all services have operated normally since 09:50 UTC.